root / pykota / trunk / debian / rules @ 1350

Revision 1350, 2.1 kB (checked in by jalet, 20 years ago)

Debian packaging files contributed by Peter Hawkins added to the project's
main tree.

  • Property svn:eol-style set to native
  • Property svn:keywords set to Author Date Id Revision
Line 
1#!/usr/bin/make -f
2# -*- makefile -*-
3# Sample debian/rules that uses debhelper.
4# GNU copyright 1997 to 1999 by Joey Hess.
5
6# Uncomment this to turn on verbose mode.
7#export DH_VERBOSE=1
8
9export DH_COMPAT=3
10
11
12build: build-stamp
13build-stamp: 
14       dh_testdir
15
16       #/usr/bin/docbook-to-man debian/pykota.sgml > pykota.1
17       /usr/bin/python setup.py build
18       (cd docs; make -f ../debian/Makefile.docs build)
19
20       touch build-stamp
21
22clean:
23       dh_testdir
24       dh_testroot
25       rm -f build-stamp
26
27       /usr/bin/python setup.py clean --all
28       (cd docs; make -f ../debian/Makefile.docs clean)
29       rm -f pykota/__init__.pyc pykota/version.pyc
30
31       dh_clean 
32
33install: build
34       dh_testdir
35       dh_testroot
36       dh_clean -k 
37       dh_installdirs
38
39       /usr/bin/python setup.py install --prefix=`pwd`/debian/pykota/usr --no-compile
40
41       install -m 644 conf/pykota.conf.sample $(CURDIR)/debian/pykota/etc/pykota/pykota.conf
42       install -m 640 conf/pykotadmin.conf.sample $(CURDIR)/debian/pykota/etc/pykota/pykotadmin.conf
43       install -m 644 debian/etc/default/printquota $(CURDIR)/debian/pykota/etc/default/printquota
44
45       (cd docs; make -f ../debian/Makefile.docs install DESTDIR=$(CURDIR)/debian/pykota/)
46
47
48# Build architecture-dependent files here.
49binary-arch: build install
50# We have nothing to do by default.
51
52# Build architecture-independent files here.
53binary-arch: build install
54       dh_testdir
55       dh_testroot
56       dh_installchangelogs 
57       dh_installdocs
58       dh_installexamples
59#      dh_install
60#      dh_installmenu
61#      dh_installdebconf       
62#      dh_installlogrotate
63#      dh_installemacsen
64#      dh_installpam
65#      dh_installmime
66#      dh_installinit
67       dh_installcron
68#      dh_installinfo
69       dh_installman
70       dh_link
71#      dh_strip
72       dh_compress
73       dh_fixperms
74#      dh_perl
75       dh_python
76#      dh_makeshlibs
77       dh_installdeb
78#      dh_shlibdeps
79       dh_gencontrol
80       dh_md5sums
81       dh_builddeb
82
83binary: binary-indep binary-arch
84.PHONY: build clean binary-indep binary-arch binary install
Note: See TracBrowser for help on using the browser.