1 | #!/usr/bin/make -f |
---|
2 | # -*- makefile -*- |
---|
3 | # Sample debian/rules that uses debhelper. |
---|
4 | # GNU copyright 1997 to 1999 by Joey Hess. |
---|
5 | |
---|
6 | # Uncomment this to turn on verbose mode. |
---|
7 | export DH_VERBOSE=1 |
---|
8 | |
---|
9 | export DH_COMPAT=1 |
---|
10 | |
---|
11 | |
---|
12 | build: build-stamp |
---|
13 | build-stamp: |
---|
14 | dh_testdir |
---|
15 | |
---|
16 | #/usr/bin/docbook-to-man debian/pykota.sgml > pykota.1 |
---|
17 | /usr/bin/python setup.py build |
---|
18 | (cd docs; make -f ../debian/Makefile.docs build) |
---|
19 | |
---|
20 | touch build-stamp |
---|
21 | |
---|
22 | clean: |
---|
23 | dh_testdir |
---|
24 | dh_testroot |
---|
25 | rm -f build-stamp |
---|
26 | |
---|
27 | /usr/bin/python setup.py clean --all |
---|
28 | (cd docs; make -f ../debian/Makefile.docs clean) |
---|
29 | rm -f pykota/__init__.pyc pykota/version.pyc |
---|
30 | |
---|
31 | dh_clean |
---|
32 | |
---|
33 | install: build |
---|
34 | dh_testdir |
---|
35 | dh_testroot |
---|
36 | dh_clean -k |
---|
37 | dh_installdirs |
---|
38 | |
---|
39 | /usr/bin/python setup.py install --prefix=`pwd`/debian/tmp/usr --no-compile |
---|
40 | |
---|
41 | install -m 644 conf/pykota.conf.sample $(CURDIR)/debian/tmp/etc/pykota/pykota.conf |
---|
42 | install -m 640 conf/pykotadmin.conf.sample $(CURDIR)/debian/tmp/etc/pykota/pykotadmin.conf |
---|
43 | install -m 644 debian/printquota.default $(CURDIR)/debian/tmp/etc/default/printquota |
---|
44 | install -m 755 debian/pykota.cron.daily $(CURDIR)/debian/tmp/etc/cron.daily/pykota |
---|
45 | |
---|
46 | install -m 755 -g www-data -o www-data cgi-bin/printquota.cgi $(CURDIR)/debian/tmp/usr/lib/cgi-bin/printquota.cgi |
---|
47 | install -m 755 -g www-data -o www-data cgi-bin/dumpykota.cgi $(CURDIR)/debian/tmp/usr/lib/cgi-bin/dumpykota.cgi |
---|
48 | install -m 755 -g www-data -o www-data cgi-bin/pykotme.cgi $(CURDIR)/debian/tmp/usr/lib/cgi-bin/pykotme.cgi |
---|
49 | install -m 644 stylesheets/pykota.css $(CURDIR)/debian/tmp/var/www/pykota.css |
---|
50 | install -m 644 logos/pykotasmall.png $(CURDIR)/debian/tmp/var/www/pykota.png |
---|
51 | install -m 644 initscripts/README $(CURDIR)/debian/tmp/usr/share/doc/pykota/initscripts/README |
---|
52 | install -m 644 initscripts/ldap/pykota-sample.ldif $(CURDIR)/debian/tmp/usr/share/doc/pykota/initscripts/ldap/pykota-sample.ldif |
---|
53 | install -m 644 initscripts/ldap/pykota.schema $(CURDIR)/debian/tmp/etc/ldap/schema/pykota.schema |
---|
54 | install -m 644 initscripts/ldap/README.ldap $(CURDIR)/debian/tmp/usr/share/doc/pykota/initscripts/ldap/README.ldap |
---|
55 | install -m 644 initscripts/sqlite/README.sqlite $(CURDIR)/debian/tmp/usr/share/doc/pykota/initscripts/sqlite/README.sqlite |
---|
56 | install -m 644 initscripts/sqlite/pykota-sqlite.sql $(CURDIR)/debian/tmp/usr/share/doc/pykota/initscripts/sqlite/pykota-sqlite.sql |
---|
57 | install -m 644 initscripts/mysql/README.mysql $(CURDIR)/debian/tmp/usr/share/doc/pykota/initscripts/mysql/README.mysql |
---|
58 | install -m 644 initscripts/mysql/pykota-mysql.sql $(CURDIR)/debian/tmp/usr/share/doc/pykota/initscripts/mysql/pykota-mysql.sql |
---|
59 | install -m 644 initscripts/postgresql/README.postgresql $(CURDIR)/debian/tmp/usr/share/doc/pykota/initscripts/postgresql/README.postgresql |
---|
60 | install -m 644 initscripts/postgresql/pykota-postgresql.sql $(CURDIR)/debian/tmp/usr/share/doc/pykota/initscripts/postgresql/pykota-postgresql.sql |
---|
61 | install -m 644 initscripts/postgresql/upgrade-from-before-1.03.py $(CURDIR)/debian/tmp/usr/share/doc/pykota/initscripts/postgresql/upgrade-from-before-1.03.py |
---|
62 | install -m 644 initscripts/postgresql/upgrade-to-1.14.sql $(CURDIR)/debian/tmp/usr/share/doc/pykota/initscripts/postgresql/upgrade-to-1.14.sql |
---|
63 | install -m 644 initscripts/postgresql/upgrade-to-1.16.sql $(CURDIR)/debian/tmp/usr/share/doc/pykota/initscripts/postgresql/upgrade-to-1.16.sql |
---|
64 | install -m 644 initscripts/postgresql/upgrade-to-1.19.sql $(CURDIR)/debian/tmp/usr/share/doc/pykota/initscripts/postgresql/upgrade-to-1.19.sql |
---|
65 | install -m 644 initscripts/postgresql/upgrade-to-1.21.sql $(CURDIR)/debian/tmp/usr/share/doc/pykota/initscripts/postgresql/upgrade-to-1.21.sql |
---|
66 | install -m 644 initscripts/postgresql/upgrade-to-1.23.sql $(CURDIR)/debian/tmp/usr/share/doc/pykota/initscripts/postgresql/upgrade-to-1.23.sql |
---|
67 | install -m 644 initscripts/postgresql/VERYOLDpykota-upgrade-postgresql.sql $(CURDIR)/debian/tmp/usr/share/doc/pykota/initscripts/postgresql/VERYOLDpykota-upgrade-postgresql.sql |
---|
68 | install -m 644 logos/pleaseupgrade.png $(CURDIR)/debian/tmp/usr/share/doc/pykota/logos/pleaseupgrade.png |
---|
69 | install -m 644 logos/pykotaofficialindexed.png $(CURDIR)/debian/tmp/usr/share/doc/pykota/logos/pykotaofficialindexed.png |
---|
70 | install -m 644 logos/pykotaofficialindexedsmall.png $(CURDIR)/debian/tmp/usr/share/doc/pykota/logos/pykotaofficialindexedsmall.png |
---|
71 | install -m 644 logos/pykotaofficial.png $(CURDIR)/debian/tmp/usr/share/doc/pykota/logos/pykotaofficial.png |
---|
72 | install -m 644 logos/pykotaofficialsmall.png $(CURDIR)/debian/tmp/usr/share/doc/pykota/logos/pykotaofficialsmall.png |
---|
73 | install -m 644 logos/pykota.png $(CURDIR)/debian/tmp/usr/share/doc/pykota/logos/pykota.png |
---|
74 | install -m 644 logos/pykotasmall.png $(CURDIR)/debian/tmp/usr/share/doc/pykota/logos/pykotasmall.png |
---|
75 | install -m 644 logos/pykota.xcf $(CURDIR)/debian/tmp/usr/share/doc/pykota/logos/pykota.xcf |
---|
76 | install -m 644 logos/README $(CURDIR)/debian/tmp/usr/share/doc/pykota/logos/README |
---|
77 | (chown www-data.www-data $(CURDIR)/debian/tmp/usr/lib/cgi-bin/printquota.cgi) |
---|
78 | (chown www-data.www-data $(CURDIR)/debian/tmp/usr/lib/cgi-bin/dumpykota.cgi) |
---|
79 | (chown www-data.www-data $(CURDIR)/debian/tmp/usr/lib/cgi-bin/pykotme.cgi) |
---|
80 | (chmod 755 $(CURDIR)/debian/tmp/usr/share/pykota/*) |
---|
81 | (chmod 600 $(CURDIR)/debian/tmp/usr/share/pykota/cupspykota) |
---|
82 | (cd docs; make -f ../debian/Makefile.docs install DESTDIR=$(CURDIR)/debian/tmp/) |
---|
83 | |
---|
84 | |
---|
85 | # Build architecture-dependent files here. |
---|
86 | binary-arch: build install |
---|
87 | # We have nothing to do by default. |
---|
88 | |
---|
89 | # Build architecture-independent files here. |
---|
90 | binary-arch: build install |
---|
91 | dh_testdir |
---|
92 | dh_testroot |
---|
93 | dh_installchangelogs |
---|
94 | dh_installdocs |
---|
95 | dh_installexamples |
---|
96 | # dh_install |
---|
97 | # dh_installmenu |
---|
98 | dh_installdebconf |
---|
99 | # dh_installlogrotate |
---|
100 | # dh_installemacsen |
---|
101 | # dh_installpam |
---|
102 | # dh_installmime |
---|
103 | # dh_installinit |
---|
104 | dh_installcron |
---|
105 | # dh_installinfo |
---|
106 | dh_installman |
---|
107 | dh_link |
---|
108 | # dh_strip |
---|
109 | dh_compress |
---|
110 | dh_fixperms |
---|
111 | # dh_perl |
---|
112 | dh_python |
---|
113 | # dh_makeshlibs |
---|
114 | dh_installdeb |
---|
115 | # dh_shlibdeps |
---|
116 | dh_gencontrol |
---|
117 | dh_md5sums |
---|
118 | dh_builddeb |
---|
119 | |
---|
120 | binary: binary-indep binary-arch |
---|
121 | .PHONY: build clean binary-indep binary-arch binary install |
---|