Changeset 3472

Show
Ignore:
Timestamp:
01/12/09 23:48:56 (14 years ago)
Author:
jerome
Message:

Updated installation instructions.

Files:
1 modified

Legend:

Unmodified
Added
Removed
  • pykota/trunk/docs/installation.sgml

    r3413 r3472  
    700700          <listitem> 
    701701            <para> 
    702               <application>Python</application> version 2.3 or higher. 
     702              <application>Python</application> version 2.4 or higher. 
    703703              You can download it from <ulink url="http://www.python.org">http://www.python.org</ulink>. 
    704704              While <application>PyKota</application> itself will try to preserve compatibility 
    705               with <application>Python</application> version 2.3 for the near future, some <application>Python</application> 
     705              with <application>Python</application> version 2.4 for the near future, some <application>Python</application> 
    706706              modules which are needed by <application>PyKota</application> may require a more recent version 
    707707              of this language. 
     
    810810              You can download this software from <ulink url="http://www.sourceforge.net/projects/net-snmp/">http://www.sourceforge.net/projects/net-snmp/</ulink>. 
    811811              You only need this if PyKota's internal SNMP accounting code doesn't work for your SNMP-aware 
    812               printers. 
     812              printers. In 99% of the cases, you won't need to install this. 
    813813            </para> 
    814814          </listitem> 
     
    818818              the <command>pap</command> command. 
    819819              You can download this software from <ulink url="http://netatalk.sourceforge.net/">http://netatalk.sourceforge.net/</ulink>. 
    820               You only need this if you plan to query your printers for their internal page counter via AppleTalk. 
     820              You only need this if you plan to query your printers for 
     821              their internal page counter via AppleTalk. 
     822              In 99% of the cases, you won't need to install this. 
    821823            </para> 
    822824          </listitem> 
     
    832834              You can download it from <ulink url="http://psyco.sourceforge.net">http://psyco.sourceforge.net</ulink>. 
    833835              You only need this if you run on the <literal>x86</literal> architecture because 
    834               <application>Psyco</application> doesn't yet exist on other architectures. 
     836              <application>Psyco</application> doesn't yet exist on 
     837              other architectures. 
     838              Feel free to install this or not. It might speedup the 
     839              parsing of some print jobs by <appname>PyKota</appname>. 
    835840            </para> 
    836841          </listitem> 
     
    10841089 
    10851090        <para> 
     1091          As an alternative you can simply copy it : 
     1092          <screen> 
     1093            $ cp /usr/share/pykota/cupspykota /usr/lib/cups/backend 
     1094          </screen> 
     1095        </para> 
     1096 
     1097        <para> 
    10861098          If you use CUPS v1.2 or higher, you must 
    1087           also type the following command to allow the <command>cupspykota</command> 
     1099          also type the following commands to allow the <command>cupspykota</command> 
    10881100          backend to correctly support other backends which must be run 
    10891101          as the root user (e.g. the <command>lpd</command> backend) : 
    10901102          <screen> 
     1103    $ chown root.root /usr/share/pykota/cupspykota 
    10911104    $ chmod 700 /usr/share/pykota/cupspykota 
     1105          </screen> 
     1106        </para> 
     1107 
     1108        <para> 
     1109          As an alternative, if you've copied the backend instead of 
     1110          having created a symbolic link : 
     1111          <screen> 
     1112    $ chown root.root /usr/lib/cups/backend/cupspykota 
     1113    $ chmod 700 /usr/lib/cups/backend/cupspykota 
    10921114          </screen> 
    10931115        </para>