Changeset 3264

Show
Ignore:
Timestamp:
11/29/07 10:29:01 (15 years ago)
Author:
jerome
Message:

Ensure only developers will install the latest development tree for now,
to prevent people from forming bad feelings about this (great) software.

Location:
pykota/trunk
Files:
2 modified

Legend:

Unmodified
Added
Removed
  • pykota/trunk/pykota/version.py

    r3260 r3264  
    2222"""This module defines some application level constants.""" 
    2323 
    24 __version__ = "1.27alpha2_broken_unofficial" 
     24__version__ = "1.27alpha3_BROKEN_unofficial" 
    2525 
    2626__doc__ = "PyKota : a complete Printing Quota Solution for CUPS." 
  • pykota/trunk/setup.py

    r3260 r3264  
    3737sys.path.insert(0, "pykota") 
    3838from pykota.version import __version__, __doc__ 
     39 
     40if (__version__.upper().find("BROKEN") != -1) and ("--force" not in sys.argv[1:]) : 
     41    sys.stderr.write("THIS VERSION OF PYKOTA IS BROKEN. YOU MUST NOT USE IT. YOU SHOULD DOWNLOAD AN EARLIER RELEASE INSTEAD, EITHER THROUGH AN ENTRY PASS, OR BY DOWNLOADING THE LATEST STABLE TAG FROM SUBVERSION.\n") 
     42    sys.exit(-1) 
    3943 
    4044data_files = []