Show
Ignore:
Timestamp:
09/06/06 14:46:53 (16 years ago)
Author:
jerome
Message:

Finally it's probably better to abort immediately if python-mysqldb is too old.

Files:
1 modified

Legend:

Unmodified
Added
Removed
  • pykota/trunk/pykota/storages/mysqlstorage.py

    r3009 r3010  
    5151            self.database.autocommit(1) 
    5252        except AttributeError :     
    53             self.tool.printInfo(_("Your version of python-mysqldb is too old. Please install a newer release."), "error") 
     53            raise PyKotaStorageError, _("Your version of python-mysqldb is too old. Please install a newer release.") 
    5454        self.cursor = self.database.cursor() 
    5555        self.cursor.execute("SET NAMES 'utf8';")