[1350] | 1 | #!/usr/bin/make -f |
---|
| 2 | # -*- makefile -*- |
---|
| 3 | # Sample debian/rules that uses debhelper. |
---|
| 4 | # GNU copyright 1997 to 1999 by Joey Hess. |
---|
| 5 | |
---|
| 6 | # Uncomment this to turn on verbose mode. |
---|
[1592] | 7 | export DH_VERBOSE=1 |
---|
[1350] | 8 | |
---|
[1592] | 9 | export DH_COMPAT=1 |
---|
[1350] | 10 | |
---|
| 11 | |
---|
| 12 | build: build-stamp |
---|
[2109] | 13 | build-stamp: |
---|
[2534] | 14 | dh_testdir |
---|
[1350] | 15 | |
---|
[2534] | 16 | #/usr/bin/docbook-to-man debian/pykota.sgml > pykota.1 |
---|
| 17 | /usr/bin/python setup.py build |
---|
| 18 | (cd docs; make -f ../debian/Makefile.docs build) |
---|
[2109] | 19 | |
---|
[2534] | 20 | touch build-stamp |
---|
[2109] | 21 | |
---|
[1350] | 22 | clean: |
---|
[2534] | 23 | dh_testdir |
---|
| 24 | dh_testroot |
---|
| 25 | rm -f build-stamp |
---|
[1350] | 26 | |
---|
[2534] | 27 | /usr/bin/python setup.py clean --all |
---|
| 28 | (cd docs; make -f ../debian/Makefile.docs clean) |
---|
| 29 | rm -f pykota/__init__.pyc pykota/version.pyc |
---|
[2109] | 30 | |
---|
[2534] | 31 | dh_clean |
---|
[2109] | 32 | |
---|
[1350] | 33 | install: build |
---|
[2534] | 34 | dh_testdir |
---|
| 35 | dh_testroot |
---|
| 36 | dh_clean -k |
---|
| 37 | dh_installdirs |
---|
[1350] | 38 | |
---|
[2534] | 39 | /usr/bin/python setup.py install --prefix=`pwd`/debian/tmp/usr --no-compile |
---|
[1350] | 40 | |
---|
[2534] | 41 | install -m 644 conf/pykota.conf.sample $(CURDIR)/debian/tmp/etc/pykota/pykota.conf |
---|
| 42 | install -m 640 conf/pykotadmin.conf.sample $(CURDIR)/debian/tmp/etc/pykota/pykotadmin.conf |
---|
| 43 | install -m 644 debian/printquota.default $(CURDIR)/debian/tmp/etc/default/printquota |
---|
| 44 | install -m 755 debian/pykota.cron.daily $(CURDIR)/debian/tmp/etc/cron.daily/pykota |
---|
[2109] | 45 | |
---|
[2534] | 46 | install -m 755 -g www-data -o www-data cgi-bin/printquota.cgi $(CURDIR)/debian/tmp/usr/lib/cgi-bin/printquota.cgi |
---|
| 47 | install -m 755 -g www-data -o www-data cgi-bin/dumpykota.cgi $(CURDIR)/debian/tmp/usr/lib/cgi-bin/dumpykota.cgi |
---|
| 48 | install -m 755 -g www-data -o www-data cgi-bin/pykotme.cgi $(CURDIR)/debian/tmp/usr/lib/cgi-bin/pykotme.cgi |
---|
| 49 | install -m 644 stylesheets/pykota.css $(CURDIR)/debian/tmp/var/www/pykota.css |
---|
| 50 | install -m 644 logos/pykotasmall.png $(CURDIR)/debian/tmp/var/www/pykota.png |
---|
| 51 | install -m 644 initscripts/README $(CURDIR)/debian/tmp/usr/share/doc/pykota/initscripts/README |
---|
| 52 | install -m 644 initscripts/ldap/pykota-sample.ldif $(CURDIR)/debian/tmp/usr/share/doc/pykota/initscripts/ldap/pykota-sample.ldif |
---|
| 53 | install -m 644 initscripts/ldap/pykota.schema $(CURDIR)/debian/tmp/etc/ldap/schema/pykota.schema |
---|
| 54 | install -m 644 initscripts/ldap/README.ldap $(CURDIR)/debian/tmp/usr/share/doc/pykota/initscripts/ldap/README.ldap |
---|
[2847] | 55 | install -m 644 initscripts/sqlite/README.sqlite $(CURDIR)/debian/tmp/usr/share/doc/pykota/initscripts/sqlite/README.sqlite |
---|
| 56 | install -m 644 initscripts/sqlite/pykota-sqlite.sql $(CURDIR)/debian/tmp/usr/share/doc/pykota/initscripts/sqlite/pykota-sqlite.sql |
---|
[2534] | 57 | install -m 644 initscripts/mysql/README.mysql $(CURDIR)/debian/tmp/usr/share/doc/pykota/initscripts/mysql/README.mysql |
---|
| 58 | install -m 644 initscripts/mysql/pykota-mysql.sql $(CURDIR)/debian/tmp/usr/share/doc/pykota/initscripts/mysql/pykota-mysql.sql |
---|
| 59 | install -m 644 initscripts/postgresql/README.postgresql $(CURDIR)/debian/tmp/usr/share/doc/pykota/initscripts/postgresql/README.postgresql |
---|
| 60 | install -m 644 initscripts/postgresql/pykota-postgresql.sql $(CURDIR)/debian/tmp/usr/share/doc/pykota/initscripts/postgresql/pykota-postgresql.sql |
---|
| 61 | install -m 644 initscripts/postgresql/upgrade-from-before-1.03.py $(CURDIR)/debian/tmp/usr/share/doc/pykota/initscripts/postgresql/upgrade-from-before-1.03.py |
---|
| 62 | install -m 644 initscripts/postgresql/upgrade-to-1.14.sql $(CURDIR)/debian/tmp/usr/share/doc/pykota/initscripts/postgresql/upgrade-to-1.14.sql |
---|
| 63 | install -m 644 initscripts/postgresql/upgrade-to-1.16.sql $(CURDIR)/debian/tmp/usr/share/doc/pykota/initscripts/postgresql/upgrade-to-1.16.sql |
---|
| 64 | install -m 644 initscripts/postgresql/upgrade-to-1.19.sql $(CURDIR)/debian/tmp/usr/share/doc/pykota/initscripts/postgresql/upgrade-to-1.19.sql |
---|
| 65 | install -m 644 initscripts/postgresql/upgrade-to-1.21.sql $(CURDIR)/debian/tmp/usr/share/doc/pykota/initscripts/postgresql/upgrade-to-1.21.sql |
---|
| 66 | install -m 644 initscripts/postgresql/upgrade-to-1.23.sql $(CURDIR)/debian/tmp/usr/share/doc/pykota/initscripts/postgresql/upgrade-to-1.23.sql |
---|
| 67 | install -m 644 initscripts/postgresql/VERYOLDpykota-upgrade-postgresql.sql $(CURDIR)/debian/tmp/usr/share/doc/pykota/initscripts/postgresql/VERYOLDpykota-upgrade-postgresql.sql |
---|
| 68 | install -m 644 logos/pleaseupgrade.png $(CURDIR)/debian/tmp/usr/share/doc/pykota/logos/pleaseupgrade.png |
---|
| 69 | install -m 644 logos/pykotaofficialindexed.png $(CURDIR)/debian/tmp/usr/share/doc/pykota/logos/pykotaofficialindexed.png |
---|
| 70 | install -m 644 logos/pykotaofficialindexedsmall.png $(CURDIR)/debian/tmp/usr/share/doc/pykota/logos/pykotaofficialindexedsmall.png |
---|
| 71 | install -m 644 logos/pykotaofficial.png $(CURDIR)/debian/tmp/usr/share/doc/pykota/logos/pykotaofficial.png |
---|
| 72 | install -m 644 logos/pykotaofficialsmall.png $(CURDIR)/debian/tmp/usr/share/doc/pykota/logos/pykotaofficialsmall.png |
---|
| 73 | install -m 644 logos/pykota.png $(CURDIR)/debian/tmp/usr/share/doc/pykota/logos/pykota.png |
---|
| 74 | install -m 644 logos/pykotasmall.png $(CURDIR)/debian/tmp/usr/share/doc/pykota/logos/pykotasmall.png |
---|
| 75 | install -m 644 logos/pykota.xcf $(CURDIR)/debian/tmp/usr/share/doc/pykota/logos/pykota.xcf |
---|
| 76 | install -m 644 logos/README $(CURDIR)/debian/tmp/usr/share/doc/pykota/logos/README |
---|
[3214] | 77 | install -m 644 qa-assistant/pykota.xml $(CURDIR)/debian/tmp/usr/share/qa-assistant/data/pykota.xml |
---|
[2534] | 78 | (chown www-data.www-data $(CURDIR)/debian/tmp/usr/lib/cgi-bin/printquota.cgi) |
---|
| 79 | (chown www-data.www-data $(CURDIR)/debian/tmp/usr/lib/cgi-bin/dumpykota.cgi) |
---|
| 80 | (chown www-data.www-data $(CURDIR)/debian/tmp/usr/lib/cgi-bin/pykotme.cgi) |
---|
| 81 | (cd docs; make -f ../debian/Makefile.docs install DESTDIR=$(CURDIR)/debian/tmp/) |
---|
[2109] | 82 | |
---|
| 83 | |
---|
[1350] | 84 | # Build architecture-dependent files here. |
---|
| 85 | binary-arch: build install |
---|
| 86 | # We have nothing to do by default. |
---|
| 87 | |
---|
| 88 | # Build architecture-independent files here. |
---|
| 89 | binary-arch: build install |
---|
[2534] | 90 | dh_testdir |
---|
| 91 | dh_testroot |
---|
[3234] | 92 | dh_installchangelogs |
---|
[2534] | 93 | dh_installdocs |
---|
| 94 | dh_installexamples |
---|
| 95 | # dh_install |
---|
| 96 | # dh_installmenu |
---|
| 97 | dh_installdebconf |
---|
| 98 | # dh_installlogrotate |
---|
| 99 | # dh_installemacsen |
---|
| 100 | # dh_installpam |
---|
| 101 | # dh_installmime |
---|
| 102 | # dh_installinit |
---|
| 103 | dh_installcron |
---|
| 104 | # dh_installinfo |
---|
| 105 | dh_installman |
---|
| 106 | dh_link |
---|
| 107 | # dh_strip |
---|
| 108 | dh_compress |
---|
| 109 | dh_fixperms |
---|
| 110 | # dh_perl |
---|
[3237] | 111 | dh_python |
---|
[2534] | 112 | # dh_makeshlibs |
---|
| 113 | dh_installdeb |
---|
| 114 | # dh_shlibdeps |
---|
| 115 | dh_gencontrol |
---|
| 116 | dh_md5sums |
---|
| 117 | dh_builddeb |
---|
[1350] | 118 | |
---|
| 119 | binary: binary-indep binary-arch |
---|
| 120 | .PHONY: build clean binary-indep binary-arch binary install |
---|