[1350] | 1 | #!/usr/bin/make -f |
---|
| 2 | # -*- makefile -*- |
---|
| 3 | # Sample debian/rules that uses debhelper. |
---|
| 4 | # GNU copyright 1997 to 1999 by Joey Hess. |
---|
| 5 | |
---|
| 6 | # Uncomment this to turn on verbose mode. |
---|
[1592] | 7 | export DH_VERBOSE=1 |
---|
[1350] | 8 | |
---|
[1592] | 9 | export DH_COMPAT=1 |
---|
[1350] | 10 | |
---|
| 11 | |
---|
| 12 | build: build-stamp |
---|
| 13 | build-stamp: |
---|
[1592] | 14 | dh_testdir |
---|
| 15 | |
---|
| 16 | #/usr/bin/docbook-to-man debian/pykota.sgml > pykota.1 |
---|
| 17 | /usr/bin/python setup.py build |
---|
| 18 | (cd docs; make -f ../debian/Makefile.docs build) |
---|
| 19 | |
---|
| 20 | touch build-stamp |
---|
[1350] | 21 | |
---|
| 22 | clean: |
---|
[1592] | 23 | dh_testdir |
---|
| 24 | dh_testroot |
---|
| 25 | rm -f build-stamp |
---|
| 26 | |
---|
| 27 | /usr/bin/python setup.py clean --all |
---|
| 28 | (cd docs; make -f ../debian/Makefile.docs clean) |
---|
| 29 | rm -f pykota/__init__.pyc pykota/version.pyc |
---|
| 30 | |
---|
| 31 | dh_clean |
---|
[1350] | 32 | |
---|
| 33 | install: build |
---|
[1592] | 34 | dh_testdir |
---|
| 35 | dh_testroot |
---|
| 36 | dh_clean -k |
---|
| 37 | dh_installdirs |
---|
| 38 | |
---|
| 39 | /usr/bin/python setup.py install --prefix=`pwd`/debian/tmp/usr --no-compile |
---|
| 40 | |
---|
| 41 | install -m 644 conf/pykota.conf.sample $(CURDIR)/debian/tmp/etc/pykota/pykota.conf |
---|
| 42 | install -m 640 conf/pykotadmin.conf.sample $(CURDIR)/debian/tmp/etc/pykota/pykotadmin.conf |
---|
| 43 | install -m 644 debian/printquota-default $(CURDIR)/debian/tmp/etc/default/printquota |
---|
| 44 | |
---|
| 45 | install -m 755 -g www-data -o www-data cgi-bin/printquota.cgi $(CURDIR)/debian/tmp/usr/lib/cgi-bin/printquota.cgi |
---|
| 46 | install -m 644 stylesheets/pykota.css $(CURDIR)/debian/tmp/var/www/pykota.css |
---|
| 47 | install -m 644 logos/pykotasmall.png $(CURDIR)/debian/tmp/var/www/pykota.png |
---|
| 48 | install -m 644 initscripts/README $(CURDIR)/debian/tmp/usr/share/doc/pykota/initscripts/README |
---|
| 49 | install -m 644 initscripts/ldap/pykota-sample.ldif $(CURDIR)/debian/tmp/usr/share/doc/pykota/initscripts/ldap/pykota-sample.ldif |
---|
| 50 | install -m 644 initscripts/ldap/pykota.schema $(CURDIR)/debian/tmp/usr/share/doc/pykota/initscripts/ldap/pykota.schema |
---|
| 51 | install -m 644 initscripts/ldap/README.ldap $(CURDIR)/debian/tmp/usr/share/doc/pykota/initscripts/ldap/README.ldap |
---|
| 52 | install -m 644 initscripts/postgresql/README.postgresql $(CURDIR)/debian/tmp/usr/share/doc/pykota/initscripts/postgresql/README.postgresql |
---|
| 53 | install -m 644 initscripts/postgresql/pykota-postgresql.sql $(CURDIR)/debian/tmp/usr/share/doc/pykota/initscripts/postgresql/pykota-postgresql.sql |
---|
| 54 | install -m 644 initscripts/postgresql/upgrade-from-before-1.03.py $(CURDIR)/debian/tmp/usr/share/doc/pykota/initscripts/postgresql/upgrade-from-before-1.03.py |
---|
| 55 | install -m 644 initscripts/postgresql/upgrade-to-1.14.sql $(CURDIR)/debian/tmp/usr/share/doc/pykota/initscripts/postgresql/upgrade-to-1.14.sql |
---|
| 56 | install -m 644 initscripts/postgresql/upgrade-to-1.16.sql $(CURDIR)/debian/tmp/usr/share/doc/pykota/initscripts/postgresql/upgrade-to-1.16.sql |
---|
| 57 | install -m 644 initscripts/postgresql/upgrade-to-1.19.sql $(CURDIR)/debian/tmp/usr/share/doc/pykota/initscripts/postgresql/upgrade-to-1.19.sql |
---|
| 58 | install -m 644 initscripts/postgresql/VERYOLDpykota-upgrade-postgresql.sql $(CURDIR)/debian/tmp/usr/share/doc/pykota/initscripts/postgresql/VERYOLDpykota-upgrade-postgresql.sql |
---|
| 59 | install -m 644 logos/pleaseupgrade.png $(CURDIR)/debian/tmp/usr/share/doc/pykota/logos/pleaseupgrade.png |
---|
| 60 | install -m 644 logos/pykotaofficialindexed.png $(CURDIR)/debian/tmp/usr/share/doc/pykota/logos/pykotaofficialindexed.png |
---|
| 61 | install -m 644 logos/pykotaofficialindexedsmall.png $(CURDIR)/debian/tmp/usr/share/doc/pykota/logos/pykotaofficialindexedsmall.png |
---|
| 62 | install -m 644 logos/pykotaofficial.png $(CURDIR)/debian/tmp/usr/share/doc/pykota/logos/pykotaofficial.png |
---|
| 63 | install -m 644 logos/pykotaofficialsmall.png $(CURDIR)/debian/tmp/usr/share/doc/pykota/logos/pykotaofficialsmall.png |
---|
| 64 | install -m 644 logos/pykota.png $(CURDIR)/debian/tmp/usr/share/doc/pykota/logos/pykota.png |
---|
| 65 | install -m 644 logos/pykotasmall.png $(CURDIR)/debian/tmp/usr/share/doc/pykota/logos/pykotasmall.png |
---|
| 66 | install -m 644 logos/pykota.xcf $(CURDIR)/debian/tmp/usr/share/doc/pykota/logos/pykota.xcf |
---|
| 67 | install -m 644 logos/README $(CURDIR)/debian/tmp/usr/share/doc/pykota/logos/README |
---|
| 68 | (chown www-data.www-data $(CURDIR)/debian/tmp/usr/lib/cgi-bin/printquota.cgi) |
---|
| 69 | (chmod 755 $(CURDIR)/debian/tmp/usr/share/pykota/*) |
---|
| 70 | (cd docs; make -f ../debian/Makefile.docs install DESTDIR=$(CURDIR)/debian/tmp/) |
---|
[1350] | 71 | |
---|
| 72 | |
---|
| 73 | # Build architecture-dependent files here. |
---|
| 74 | binary-arch: build install |
---|
| 75 | # We have nothing to do by default. |
---|
| 76 | |
---|
| 77 | # Build architecture-independent files here. |
---|
| 78 | binary-arch: build install |
---|
[1592] | 79 | dh_testdir |
---|
| 80 | dh_testroot |
---|
| 81 | dh_installchangelogs |
---|
| 82 | dh_installdocs |
---|
| 83 | dh_installexamples |
---|
| 84 | # dh_install |
---|
| 85 | # dh_installmenu |
---|
| 86 | # dh_installdebconf |
---|
| 87 | # dh_installlogrotate |
---|
| 88 | # dh_installemacsen |
---|
| 89 | # dh_installpam |
---|
| 90 | # dh_installmime |
---|
| 91 | # dh_installinit |
---|
| 92 | dh_installcron |
---|
| 93 | # dh_installinfo |
---|
| 94 | dh_installman |
---|
| 95 | dh_link |
---|
| 96 | # dh_strip |
---|
| 97 | dh_compress |
---|
| 98 | dh_fixperms |
---|
| 99 | # dh_perl |
---|
| 100 | dh_python |
---|
| 101 | # dh_makeshlibs |
---|
| 102 | dh_installdeb |
---|
| 103 | # dh_shlibdeps |
---|
| 104 | dh_gencontrol |
---|
| 105 | dh_md5sums |
---|
| 106 | dh_builddeb |
---|
[1350] | 107 | |
---|
| 108 | binary: binary-indep binary-arch |
---|
| 109 | .PHONY: build clean binary-indep binary-arch binary install |
---|