root / pkpgcounter / trunk / debian / rules @ 458

Revision 458, 2.1 kB (checked in by jerome, 17 years ago)

Added Debian packaging stuff.

  • Property svn:executable set to *
Line 
1#!/usr/bin/make -f
2# -*- makefile -*-
3# Sample debian/rules that uses debhelper.
4# This file was originally written by Joey Hess and Craig Small.
5# As a special exception, when this file is copied by dh-make into a
6# dh-make output file, you may use that output file without restriction.
7# This special exception was added by Craig Small in version 0.37 of dh-make.
8
9# Uncomment this to turn on verbose mode.
10#export DH_VERBOSE=1
11
12
13
14
15CFLAGS = -Wall -g
16
17ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
18        CFLAGS += -O0
19else
20        CFLAGS += -O2
21endif
22
23configure: configure-stamp
24configure-stamp:
25        dh_testdir
26        # Add here commands to configure the package.
27       
28        touch configure-stamp
29
30
31build: build-stamp
32
33build-stamp: configure-stamp 
34        dh_testdir
35
36        # Add here commands to compile the package.
37        #$(MAKE)
38        python setup.py build
39        #docbook-to-man debian/pkpgcounter.sgml > pkpgcounter.1
40
41        touch build-stamp
42
43clean:
44        dh_testdir
45        dh_testroot
46        rm -f build-stamp configure-stamp
47
48        # Add here commands to clean up after the build process.
49        #-$(MAKE) clean
50        python setup.py clean --all
51        rm -f pkpgpdls/version.pyc pkpgpdls/__init__.pyc
52
53        dh_clean 
54
55install: build
56        dh_testdir
57        dh_testroot
58        dh_clean -k 
59        dh_installdirs
60
61        # Add here commands to install the package into debian/pkpgcounter.
62        #$(MAKE) install DESTDIR=$(CURDIR)/debian/pkpgcounter
63        python setup.py install --prefix $(CURDIR)/debian/pkpgcounter/usr --no-compile
64
65
66# Build architecture-independent files here.
67binary-indep: build install
68# We have nothing to do by default.
69
70# Build architecture-dependent files here.
71binary-arch: build install
72        dh_testdir
73        dh_testroot
74        dh_installchangelogs 
75        dh_installdocs
76        dh_installexamples
77#       dh_install
78#       dh_installmenu
79        dh_installdebconf       
80#       dh_installlogrotate
81#       dh_installemacsen
82#       dh_installpam
83#       dh_installmime
84#       dh_installinit
85#       dh_installcron
86#       dh_installinfo
87        dh_installman
88        dh_link
89        dh_strip
90        dh_compress
91        dh_fixperms
92#       dh_perl
93        dh_pysupport
94#       dh_makeshlibs
95        dh_installdeb
96#       dh_shlibdeps
97        dh_gencontrol
98        dh_md5sums
99        dh_builddeb
100
101binary: binary-indep binary-arch
102.PHONY: build clean binary-indep binary-arch binary install configure
Note: See TracBrowser for help on using the browser.